User Tools

Site Tools


misc:upgrading_browser

Browser Requirements

For the sake of the health of the internet, please use one of the following modern browsers:

Support for Front End

Realgeeks supports the following browsers for all client facing pages:

  • Google Chrome
  • Firefox
  • Internet Explorer 9+
  • Safari 7+

Can't Get Away from IE6?

It's understandable if your MLS, banking or other enterprise service requires you to use Internet Explorer, but that doesn't mean you can't also use a more modern browser.

Run multiple browsers

Switch to a modern browser for your daily usage, and use Internet Explorer only to access those broken sites.

Run a modern browser and embed IE

Firefox and chrome support (via extensions) embedding an Internet Explorer frame within your browser, and it can be set up to do so for a whitelist of sites.

misc/upgrading_browser.txt · Last modified: 2015/12/15 20:37 by kaitlin